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Smart Cellular Module                                                                                         

 

 

1.0 Device Overview: 
The SCM-1 is a small form factor, low power cellular cloud-
based module, it provides verity of analog and digital 
functionality. It has been designed with LTE Category-M1 
and NB-IoT cellular technologies. LTE Category-M1and NB-
IoT are low-power wide area (LPWA) cellular technologies, 
both are specifically designed for the Internet of Things 
(IoT) and machine-to-machine (M2M) communications. 

Features  

• Supports LTE Cat. -M1 and NB-IoT 

technologies. 

•  Low Power  

• Small form factor (1.524”X2.045”) 

• Better coverage than regular cellular networks. 

• Has the priority over other cellular networks  

 

 

 

   Applications: 

• Measuring and controlling systems 

• Industrial applications 

• Smart lighting control 

• Smart irrigation system 

• Gas leak detection 
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2.0 Pin Assignments:  
This part shows pin assignments of the SCM-1. It has 37 pins with different functions which are shown in 

the figure and the table below.   

 
              Fig2.1: SCM-1 Diagram 

 

Table1: Pin Assignments  

# Pin name Function Description  
1 P0.05 Digital I/O (SoC) General purpose I/O 

2 P0.06 Digital I/O (SoC) General purpose I/O 

3 P0.07 Digital I/O (SoC) General purpose I/O 

4 IO_SUPPLY Power Reserved for Nordic use 

5 P0.08 Digital I/O (SoC) General purpose I/O 

6 P0.09 Digital I/O (SoC) General purpose I/O 

7 P0.10 Digital I/O (SoC) General purpose I/O 

8 P0.11 Digital I/O (SoC) General purpose I/O 

9 P0.12 Digital I/O (SoC) General purpose I/O 

10 P0.13/ AIN0 Digital I/O (SoC)/ Analog 
input 

General purpose I/O/ Analog input 

11 P0.14/ AIN1 Digital I/O (SoC)/ Analog 
input 

General purpose I/O/ Analog input 
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12 P0.15/ AIN2 Digital I/O (SoC)/ Analog 
input 

General purpose I/O/ Analog input 

13 P0.16/AIN3 Digital I/O (SoC)/ Analog 
input 

General purpose I/O/ Analog input 

14 P0.17/AIN4 Digital I/O (SoC)/ Analog 
input 

General purpose I/O/ Analog input 

15 P0.18/AIN5 Digital I/O (SoC)/ Analog 
input 

General purpose I/O/ Analog input 

16 P0.19/AIN6 Digital I/O (SoC)/ Analog 
input 

General purpose I/O/ Analog input 

17 nRESET Digital I/O (SoC) System reset 

18 SWDCLK Digital input Serial wire debug clock input for debug and 
programming 

19 SWDIO Digital I/O Serial wire debug I/O for debug and 
programming 

20 P0.20/AIN7 Digital I/O (SoC)/ Analog 
input 

General purpose I/O/ Analog input 

21 P0.21/TRACECLK Digital I/O (SoC)/ Trace 
clock 

General purpose I/O/ Trace buffer clock 
(optional). 

22 P0.22/ 
TRACEDATA0 

Digital I/O (SoC)/ Trace 
data 

General purpose I/O/Trace buffer TRACEDATA 
[0] (optional). 

23 P0.23/TRACEDATA1 Digital I/O (SoC)/ Trace 
data 

General purpose I/O /Trace buffer TRACEDATA 
[1] (optional) 

24 P0.24/ 
TRACEDATA2 

Digital I/O (SoC)/ Trace 
data 

General purpose I/O/ Trace buffer TRACEDATA 
[2] (optional). 

25 P0.25/ 
TRACEDATA3 

Digital I/O (SoC)/ Trace 
data 

General purpose I/O/ Trace buffer TRACEDATA 
[3] (optional). 

26 MAGPIO2 Digital I/O (SoC) Reserved for Nordic use 

27 MAGPIO1 Digital I/O (SoC) Reserved for Nordic use 

28 GPS RF GPS receiver input 

29 SCLK Digital I/O (SoC) Reserved for Nordic use 

30 SDATA Digital I/O (SoC) Reserved for Nordic use 

31 VDD Power Supply voltage 

32 GND0 Power Ground 

33 GND1 Power Ground 

34 GND2 Power Ground 

35 GND3 Power Ground 

36 GND4 Power Ground 

37 GND5 Power Ground 

38 P0.26 Digital I/O (SoC) General purpose I/O 

39 P0.27 Digital I/O (SoC) General purpose I/O 

40 P0.28 Digital I/O (SoC) General purpose I/O 

41 P0.29 Digital I/O (SoC) General purpose I/O 

42 P0.30 Digital I/O (SoC) General purpose I/O 
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43 P0.31 Digital I/O (SoC) General purpose I/O 

44 COEX2 Digital I/O (SoC) Coexistence interface 

45 COEX1 Digital I/O (SoC) Coexistence interface 

46 COEX0 Digital I/O (SoC) Coexistence interface 

47 P0.00 Digital I/O (SoC) General purpose I/O 

48 P0.01 Digital I/O (SoC) General purpose I/O 

49 P0.02 Digital I/O (SoC) General purpose I/O 

50 P0.03 Digital I/O (SoC) General purpose I/O 

51 P0.04 Digital I/O (SoC) General purpose I/O 

 

3.0 Dimensions and Footprint: 
Figure 2 shows the dimensions and footprint of the SCM-1. 

 

 
Fig3.1: SCM-1 Dimensions and footprint 

  
 

 



 
 

 
 5 Jul2019 
 

4.0 Technical and Environmental Specifications: 
Tables 4.1 and 4.2 show the environmental and technical specifications for the SCM-1.  

4.1Recommended Operation Conditions  
 

Table2: Recommended Operation Conditions  

Symbol Parameter Notes Min. Nom. Max. Units 

VDD 
Battery input 
voltage 

- Including voltage drop, ripple 
and spikes. 
- RF 3GPP compliancy requires 
3.3 V. 

3.0 3.8 5.5 V 

GPIOH 
GPIO high level 
voltage 

   VDD_GPIO V 

MAGPIOH 
MAGPIO high level 
voltage 

  1.8 1.8 V 

TA 
Operating 
temperature 

 -40 25 85 °C 

 

4.2 Absolute Maximum Ratings 
Table3: Absolute Ratings  

 Min. Max. Unit 

VDD -0.3 5.5 V 

Storage temperature -40 125 °C 

Moisture Sensitivity 
Level (MSL) 

 2  
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4.3 Block Diagram 

 

 
Fig4.1: SCM-1 Block Diagrm  

 

5.0 Software configuration: 
This section is a detailed introduction to the software configuration including development tools and 

coding.  

 

5.1 Getting Started  

Requirements:  

• SCM-1  

• nRF9160 DK 

• Windows, macOS or Linux PC  

• nanoSIM card supporting LTE-Cat.M1 

• microUSB cable 
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Header Pin (SCM-1) Function DK Connection 

1 3.3V VTG                                     

2 SWDIO SWDIO                        

3 SWCLK SWDCLK                      

4 P1.00 SWO                            

5 RESET RESET                              

6 GND GNDDET                           

 

5.2 Development Tools 

To get started with nRF DK and the SCM-1 install the nRF connect for desktop. 
 

1- Go to Nordic Semiconductor Website. Click here 

 

2- Click on Software and tools. 

 
Fig5.1: Software and Tools  

 

 

 

 

 

 

 
 

 

 

 

 

https://www.nordicsemi.com/
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3- Click on Development Tools and choose nRF Connect for Desktop.  

 

 
Fig5.2: nRF Connect for Desktop 

 

4- Choose your platform, Download and Run the latest version of nRF Connect for 

Desktop. 

 
Fig 5.3: Platform Choosing   
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5- After you download it on your desktop go to Settings and check for updates. 

  

 

 

 

 

 

 

 

 

 

 

 

Fig5.4: Settings  

 

6- Go to Add/Remove Apps, Install Getting Started Assistant and Programmer.  

 

 
 

Fig 5.5: Getting Started Assistant  
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Fig 5.6: Programmer Install 
 
 
 
 

7- Go to launch app, and launch Getting Started Assistant. 

 
 

 
Fig 5.7: Launch Apps 
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8- Follow the steps from 1 to 4 to finish installation. 

 

 

 
Fig 5.8: Install the toolchain  

 
9- The first step starts with opening your Command Prompt, make a right click, and choose 

Run as administrator. 
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Fig 5.9: Command Prompt  

10- Enter commands as described.  

 
Fig 5.10: Installing Steps  

 

Note: At the end of Step 1 create a new folder (c: \gnuarmemb) and install GNU ARM 

Embedded toolchain into it as mentioned.  
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11- Verify all commands in step one and move to the next step. 

 

 
Fig 5.11: Verify Commands  
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12- In step 3 be sure to download the Segger Embedded Studio using the link attached in step 3. 

 

 
Fig 5.12: Segger Embedded Studio in Step 3  

 

 

13- After downloading and extracting Segger Embedded Studio files (Step 3) go to bin, make a 

shortcut of Segger Embedded Studio and move it to your desktop.  
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Fig 5.13: Segger Studio shortcut  

 

14- Open the Segger Studio and complete the next two steps as described. 

 

 
 Fig 5.14: Installation Steps  
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15- Open SEGGER Embedded Studio which was installed in step 3. 

 
Fig 5.15:Segger Embedded Studio 
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16- As mentioned in Step 4 click Tools > Options and select the nRF Connect tab. 

 
 

 
Fig 5.16: Project Setup  
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17- Go to File > Open nRF connect SDK project. 

 
 

Fig 5.17:Open nRF Project 
 

18- Set CMakeLists.txt, Board Directory, Board Name and Build Directory. Notice that you will 

be able to run this program only before erasing your nRF9160 or reprogram it.  

 

 
Fig 5.18: Connect Options 
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19- Plug the nRF9160 DK to your computer and go to Build > Build Solution 

 
Fig 5.19: Build Solution 

 

The sample will be compiled when you click Build Solution, but the nRF9160 board will not be 

programmed yet.  
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20- Before start programming you need to update Modem Firmware. Go back to Nordic 

semiconductor website > Software and tools >Development kits>nRF9160 DK.   
 

 
Fig 5.20: Modem Update 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

https://www.nordicsemi.com/
https://www.nordicsemi.com/
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21- Download the latest version of the Modem Firmware.  

 

Fig 5.21: Modem Firmware Download  
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22- Go back to the nRF Connect, click launch other App to launch Programmer.  

 

 
Fig 5.22: Other App Launch  

 

23- Launch Programmer.  

 

 
Fig 5.23: Programmer Launch  
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24- Select your device and update modem firmware when its ready (The nRF9160 has to be 

connected to your computer).  

 

 
Fig 5.24: Modem firmware Update  
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25- Open the modem firmware zip file and click write.  

 
Fig 5.25: Modem firmware zip file  

 
 

 

Note: To activate your eSIM attached with the nRF9061 Dev kit follow the direction here (nordicsemi.com/ 

GetStarted) 

 
Fig 5.26: Getting Started Video   

 
 

https://www.nordicsemi.com/Software-and-Tools/Development-Kits/nRF9160-DK/GetStarted
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26- After updating the firmware go back to Segger Studio, select Target > Connect J-Link  

 
Fig 5.27: Connect J-Link  

 
 

 
 Fig 5.28: J-Link Connectiong  
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27- Click on the green arrow to program the board  

 
 

28- After the board programs press it again to run the program. 

  

Fig 5.29: Programming 
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29- To connect your nRF9160 to the the nRF Connect for Cloud follow the directions here.  

 

30- To monitor your program, you need to have a console application. We are using Tera Term. 

in case you don’t have a console application you can download Tera Term by clicking here .  

 

 

31- Go to Tera Term  

 

 
Fig 5.30: Tera Term 

 

 

 

 

 

 

 

 

 

 

 

 

https://devzone.nordicsemi.com/nordic/cellular-iot-guides/b/getting-started-cellular/posts/getting-started-with-nrf9160-dk
https://tera-term.en.lo4d.com/windows
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32- Go to Setup>>Serial Port and set your serial port settings, to figure the correct port 

between the 3 serial ports, try all of them and message will appear when it’s right port.  

 

 
 
 

 
Fig 5.31: Serial Port Setup  
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To program SCM-1 you need to connect SCM-1 to the nRF9160. Connect the p1 header 

on the cellular module to the NORDIC Nrf9160 development kit p15 header. When 

power is applied to the module you will be able to program and debug, as if it were the 

onboard chip. 

 

 

                                                                                                                                                                                                                                                               

 

                                                                              p1 

 

 

 

 

 

Fig5.32: SCM-1 

 

 
 

                  p15        

 

 

 

 

 

 

 
Fig5.33: nRF9160 DK 
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5.3 Programming  
Examples and tutorials: 
The following code is a simple sample (GPIO configuration). It toggles two LEDs and one other pin within 

a delay of 1 sec.  

 

 
 

Fig 5.34: Simple sample with the SCM-1 wiring diagram 
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nRF connect DK provides samples that shows the use of different features.  

General Zephyr Samples  

 

Fig 5.35: General Samples 

nRF Specific Samples  

 

Fig 5.36: Specific Samples 
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MQTT Simple Sample:  

The MQTT simple sample is one of the Nordic specific examples. To open and test this sample using 

Segger Studio follow the directions. 

1- Open SEGGER Embedded Studio. 

 
Fig 5.37 Segger Embedded Studio Dashboard 

 

2- Go to File > Open nRF connect SDK project. 

 
Fig 5.38 Open nRF connect SDK Project 
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3- Set CMakeLists.txt, Board Directory, Board Name and Build Directory. 

 
Fig 5.39: nRF Connect Options 

 

 
Fig 5.40: MQTT Simple Sample  
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4- To set the broker, broker port, client id, subscribe topic and publish topic go to 

Project>>Configure nRF Connect SDK Project  

 

 
Fig 5.41: Configure nRF Connect SDK Project 

 

5- Choose menuconfig  

 

 
Fig 5.42: menuconfig 
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6- Change the broker hostname to the broker you need to connect. For testing issues, you can 

choose any public broker as mosquitto, eclipse or Hivemq, then choose configure.  

  

 
Fig 5.43: menuconfig 

 
7- Plug the nRF9160 DK to your computer and go to Build > Build Solution. 

 

 
Fig 5.44: Build Solution 
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8- Go to Target > Connect J-Link, when its connected go back to Target and choose Erase All (Be 

sure to erase the board every time you change your code).  

 

 
Fig 5.45: Connect J-Link  

 

9- Click on the green arrow to program. 

 
 

Fig 5.46: Start Programming  



 
 

 
 37 Jul2019 
 

10- Run the program and use Tera Term for testing and monitoring.  

 

11- In order to test publishing and subscribing with other client you can use any MQTT App, in this 

example we used MQTT Box. 

 

 
Fig 5.47: MQTT Box App 

  

 

12- Pick a client name, change the protocol to mqtt/tcp and change the host broker to the broker 

you are using, then go to save. 

 
Fig 5.48: MQTT Box App Settings  
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13- Use your subscribe and publish topics to test publishing and subscribing.  

 

 
Fig 5.49: MQTT Client Settings 

Be sure to use your publishing topic to publish your message on the other side(client)and your 

subscribing topic to receive a message from the other side(client). Figures 5.47 and 5.48 show 

the messages that both clients get in case of publishing or subscribing.  

 

To Publish a message in this example you need to modify the example code by adding a publish 

function. We used this function to publish our test message  

data_publish(&client, MQTT_QOS_1_AT_LEAST_ONCE, "test", strlen("test")); 

 
 

 

If you don’t edit the code it will connect, and you will be able to receive messages but without 

publishing.  
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Fig 5.50: MQTT Client Settings 
 

 
Fig 5.51: Tera Term 
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AWS MQTT/TLS Sample: 

The AWS MQTT/TLS sample connects an AWS MQTT broker securely. The code of this sample is 

attached with this document at the end of this section. 

 To connect your nRF9160 to an AWS broker you need to have an AWS account. If you don’t have an 

AWS account already go to AWS IoT Console and create one, then follow the direction below to setup 

the account.  

1- After creating an AWS account, the first thing you need to do is creating a policy, so select 

Secure>>Policies>> Create a Policy. 

 

 
Fig 5.52: Creating a policy  

 

 

 

 

 

 

 

 

 

 

https://signin.aws.amazon.com/signin?redirect_uri=https%3A%2F%2Fconsole.aws.amazon.com%2Fiot%2Fhome%3Fstate%3DhashArgs%2523%26isauthcode%3Dtrue&client_id=arn%3Aaws%3Aiam%3A%3A015428540659%3Auser%2Ficebreaker&forceMobileApp=0
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2- Add the policy statements you need, and if you are not sure what policies are needed for your 

device, you can use the one in the figure.  

 
Fig 5.53: create a policy  

  

The * in figure 5.53 means that you are using all available resources.  
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2- After creating a policy, you need to create a thing that matches your client id. Select 

Manage>>Things>>Register a thing, then choose Create a single thing.  

 

 
Fig 5.54: AWS IoT 

 

 
Fig 5.55: Creating AWS IoT Thing 
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3- Add your device to the thing registry by writing your client id as a thing name.  

 

 
Fig 5.56: Creating AWS IoT Thing 
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4- You need to create a certificate for your thing.  

 
Fig 5.57: Adding a certificate  

 

5- Download and Activate the certificate and the keys.  

 

 
Fig 5.58: Certificates Download  
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6- Before attaching policy, you need to download an AWS root CA, Click Download, and click on 

one of Amazon root certificates then copy the certificate and save it where you have the keys 

and the client certificate. We used Amazon Root CA 1. 

 

 
Fig 5.59: Amazon Root CA 

 

7- You can go back and click Attach Policy. 

 

 
Fig 5.60: Attach a Policy  
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8- Select your policy and click Register Thing 

 
Fig 5.61: Adding your policy 

 

9- You need to add the certificates you downloaded to your device configuration. Go to CC-

MSIMPLE-TLS>>src>>cerificates.h  

 

 
Fig 5.62: Certificates.h directory  
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10- Copy the client certificate, private key and the Amazon root CA to certificates.h as strings then 

save. You don’t need to use the public key here.  

 

 
 

Fig 5.63: Certificates.h file  
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11- Go back to your AWS account, click on the thing you created and select Interact. The thing 

shadow is the host broker that you will need to add to your configuration.  

 

 
Fig 5.64: Thing Details 

 
 

Fig 5.65: Host Broker 
 

12- Open your Segger embedded studio, select file, Open nRF connect SDK Project and choose our 

zip file.  
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13- Select Project>>Configure nRF Connect SDK Project>>menuconfig>>MQTT simple sample. 

14- Use your new Host Broker, then choose publish and subscribe topics, and configure.  

 

 
Fig 5.66: Configure nRF Connect SDK Project 

 

 

15- Plug the nRF9160 DK to your computer and go to Build > Build Solution. 

16- Go to Target > Connect J-Link, when its connected go back to Target and choose Erase All (Be 

sure to erase the board every time you need to reprogram it).  

17- Program and run your program by clicking the green arrow.  

18- To make sure that your nRF9160 is connected to your AWS account, open TeraTerm. It should 

look like figure 5.67. 
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Fig 5.67: Tera Term  

 

19- To test publishing and subscribing using AWS MQTT Client, go back to your AWS account, select 

Activity>>MQTT Client.  

 

 
Fig 5.68: Activity 

 

20- Choose a publish and subscribe topics based on your publish and subscribe topics in the 

menuconfig (Segger Studio). Remember that you publish to a subscribe topic and you subscribe 

to a publish topic.  



 
 

 
 51 Jul2019 
 

 

 
Fig 5.69: Subscribe and publish topics  

 

 
Fig 5.70: Subscription Topic  

 

 
Fig 5.71: Publish to Topic 
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21- To Publish a Test message press on Button 2 on your nRF9160 and you will see the message 

published in your AWS account.  

 
 Fig 5.72: Test message  

 

Download the code here 

https://www.ctismartsystems.com/wp-content/uploads/2019/08/CCM-SIMPLE-TSL-2.zip

